FIX: Licensing during installation failed

    

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Article ID: Q200001

The information in this article applies to:

  • Direct I/O, version 4.0

IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information about how to do this, view the "Restoring the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key" Help topic in Regedt32.exe.

SYMPTOMS

During installation the license key is entered together with the name and/or company of the licensee. After installation the shareware notice still appears.

CAUSE

On some systems there may be a problem with the dimensions of the edit fields in the license dialog. This causes long strings to be truncated. The changed name, company or license key are written to the registry and the licensing will fail.

RESOLUTION

To correct the problem follow the directions below:

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe. Note that you should back up the registry before you edit it. If you are running Windows NT, you should also update your Emergency Repair Disk (ERD).

  1. Back up the registry.
     
  2. Review the following entries in the registry:
        HKEY_LOCAL_MACHINE\SOFTWARE\Paule\Direct I/O\CurrentVersion\Name
        HKEY_LOCAL_MACHINE\SOFTWARE\Paule\Direct I/O\CurrentVersion\Company
     
  3. Start the Direct I/O Control Panel and select the License tab.
     
  4. Copy and paste the license key sent to you during registration.
     
  5. Restart the computer.

STATUS

Ingenieurbuero Paule has confirmed this to be a problem in Direct I/O version 4.0. This problem was first corrected in Direct I/O version 4.1.


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Last modified: 2018-04-24.
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